Windows XP Community - XPHeads



Driver Scanner

COM port locked

microsoft.public.windowsxp.general




Recommended Fix - Fix Vista Errors and Optimize Performance


Driver Scanner 2009 - Free Scan Now
Reply
  #1 (permalink)  
Old 10-13-2009, 04:07 PM
Christophe
 
Posts: n/a
COM port locked
Hello,

I use XP professional 2002 SP2.

I need an old DOS program to access a external MODEM on COM1.

When I start XP and try to access the port it says that the port is not
available. Then I go into device manager => select the port => go to
resources tab and check/uncheck 'use automatic settings'.

Now when I go into DOS mode I type MODE and there it is the port is
available.

When I restart my computer the settings are not changed in device
manager, but the port is gone again, so i need to check/uncheck
the same settings and the port shows up again in Dos mode.

I have no idea how to make the port available from startup...

Thanks in advance,

Christophe.
Belgium.

Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 10-13-2009, 07:12 PM
Bernd
 
Posts: n/a
Re: COM port locked


-------- Original-Nachricht --------

> Hello,
>
> I use XP professional 2002 SP2.
>
> I need an old DOS program to access a external MODEM on COM1.
>
> When I start XP and try to access the port it says that the port is not
> available. Then I go into device manager => select the port => go to
> resources tab and check/uncheck 'use automatic settings'.
>
> Now when I go into DOS mode I type MODE and there it is the port is
> available.
>
> When I restart my computer the settings are not changed in device
> manager, but the port is gone again, so i need to check/uncheck
> the same settings and the port shows up again in Dos mode.
>
> I have no idea how to make the port available from startup...
>
> Thanks in advance,
>
> Christophe.
> Belgium.
>


Sounds like another device is potentially using the same port (a modem?)

Look with msinfo32:

Start - Run - type: msinfo32 (press Enter)
(takes you to System Information).
On the left select Hardware Resources - Conflicts/Sharing, and - IRQ's -
there should be a listing for Com 1 under IRQs, and no device should be
sharing the IRQ for Com 1 in Conflicts/Sharing or IRQs.

- Then: Components - Problem Devices - is there anything there?

Bernd
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #3 (permalink)  
Old 10-13-2009, 07:49 PM
Jose
 
Posts: n/a
Re: COM port locked
On Oct 13, 12:07*pm, Christophe <nom...@gmail.com> wrote:
> Hello,
>
> I use XP professional 2002 SP2.
>
> I need an old DOS program to access a external MODEM on COM1.
>
> When I start XP and try to access the port it says that the port is not
> available. *Then I go into device manager => select the port => go to
> resources tab and check/uncheck 'use automatic settings'.
>
> Now when I go into DOS mode I type MODE and there it is the port is
> available.
>
> When I restart my computer the settings are not changed in device
> manager, but the port is gone again, so i need to check/uncheck
> the same settings and the port shows up again in Dos mode.
>
> I have no idea how to make the port available from startup...
>
> Thanks in advance,
>
> Christophe.
> Belgium.


If it does not show up in Device Manager under Ports when you reboot,
you should verify that it shows up and is enabled in the BIOS
configuration - before XP loads. Press whatever key you need to press
to get into the BIOS.

For example, my BIOS has a setting:

Serial Port1 Address
Use this item to enable or disable the onboard COM1/2 serial ports,
and to assign each port an address.

My Parallel Port has the same thing:

Parallel Port Address
Use this item to enable or disable the onboard Parallel port, and to
assign a port address.

If they are not enabled in the BIOS, they will not show up in DM.

What do you see in DM for Ports and if you need help, what is your
system info?

Click Start, Run and in the box enter:

msinfo32

Click OK, and when the System Summary info appears, click Edit, Select
All, Copy and then paste
back here.

There will be some personal information (like System Name and User
Name), and whatever appears to
be private information to you, just delete from the pasted
information.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #4 (permalink)  
Old 10-13-2009, 09:40 PM
sgopus
 
Posts: n/a
RE: COM port locked
Generally in DOS, com port 1 is used by a serial mouse, try a different port.

"Christophe" wrote:

> Hello,
>
> I use XP professional 2002 SP2.
>
> I need an old DOS program to access a external MODEM on COM1.
>
> When I start XP and try to access the port it says that the port is not
> available. Then I go into device manager => select the port => go to
> resources tab and check/uncheck 'use automatic settings'.
>
> Now when I go into DOS mode I type MODE and there it is the port is
> available.
>
> When I restart my computer the settings are not changed in device
> manager, but the port is gone again, so i need to check/uncheck
> the same settings and the port shows up again in Dos mode.
>
> I have no idea how to make the port available from startup...
>
> Thanks in advance,
>
> Christophe.
> Belgium.
>
>

Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #5 (permalink)  
Old 10-14-2009, 11:48 AM
cvh
 
Posts: n/a
Re: COM port locked
This is the info from MSinfo Conficts/Sharing, I dont see COM1 being shared.

I/O Port 0x00000000-0x00000CF7 PCI bus
I/O Port 0x00000000-0x00000CF7 Direct memory access controller

IRQ 16 Intel(R) 82865G Graphics Controller
IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24D2
IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24DE

Memory Address 0xA0000-0xBFFFF PCI bus
Memory Address 0xA0000-0xBFFFF Intel(R) 82865G Graphics Controller

I have one problem device, but its my modem that I have disabled:
Sportster Voice 33.6 PnP SERENUM\USR0007\5&23DE782&0&0000 This device is
disabled.


"Christophe" <nomail@gmail.com> wrote in message
news:eMVDw8BTKHA.1236@TK2MSFTNGP05.phx.gbl...
> Hello,
>
> I use XP professional 2002 SP2.
>
> I need an old DOS program to access a external MODEM on COM1.
>
> When I start XP and try to access the port it says that the port is not
> available. Then I go into device manager => select the port => go to
> resources tab and check/uncheck 'use automatic settings'.
>
> Now when I go into DOS mode I type MODE and there it is the port is
> available.
>
> When I restart my computer the settings are not changed in device manager,
> but the port is gone again, so i need to check/uncheck
> the same settings and the port shows up again in Dos mode.
>
> I have no idea how to make the port available from startup...
>
> Thanks in advance,
>
> Christophe.
> Belgium.
>



Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #6 (permalink)  
Old 10-14-2009, 11:50 AM
cvh
 
Posts: n/a
Re: COM port locked
I have only one com port in my PC and that is COM1


"sgopus" <sgopus@discussions.microsoft.com> wrote in message
news:89CC76F6-79C7-4388-AAF5-9BF320A57F2D@microsoft.com...
> Generally in DOS, com port 1 is used by a serial mouse, try a different
> port.
>
> "Christophe" wrote:
>
>> Hello,
>>
>> I use XP professional 2002 SP2.
>>
>> I need an old DOS program to access a external MODEM on COM1.
>>
>> When I start XP and try to access the port it says that the port is not
>> available. Then I go into device manager => select the port => go to
>> resources tab and check/uncheck 'use automatic settings'.
>>
>> Now when I go into DOS mode I type MODE and there it is the port is
>> available.
>>
>> When I restart my computer the settings are not changed in device
>> manager, but the port is gone again, so i need to check/uncheck
>> the same settings and the port shows up again in Dos mode.
>>
>> I have no idea how to make the port available from startup...
>>
>> Thanks in advance,
>>
>> Christophe.
>> Belgium.
>>
>>



Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #7 (permalink)  
Old 10-14-2009, 11:51 AM
cvh
 
Posts: n/a
Re: COM port locked

"Jose" <jose_ease@yahoo.com> wrote in message
news:a48f0eb2-5043-4f34-8f1d-acd403965a6a@b2g2000yqi.googlegroups.com...
On Oct 13, 12:07 pm, Christophe <nom...@gmail.com> wrote:
> Hello,
>
> I use XP professional 2002 SP2.
>
> I need an old DOS program to access a external MODEM on COM1.
>
> When I start XP and try to access the port it says that the port is not
> available. Then I go into device manager => select the port => go to
> resources tab and check/uncheck 'use automatic settings'.
>
> Now when I go into DOS mode I type MODE and there it is the port is
> available.
>
> When I restart my computer the settings are not changed in device
> manager, but the port is gone again, so i need to check/uncheck
> the same settings and the port shows up again in Dos mode.
>
> I have no idea how to make the port available from startup...
>
> Thanks in advance,
>
> Christophe.
> Belgium.


If it does not show up in Device Manager under Ports when you reboot,
you should verify that it shows up and is enabled in the BIOS
configuration - before XP loads. Press whatever key you need to press
to get into the BIOS.

For example, my BIOS has a setting:

Serial Port1 Address
Use this item to enable or disable the onboard COM1/2 serial ports,
and to assign each port an address.

My Parallel Port has the same thing:

Parallel Port Address
Use this item to enable or disable the onboard Parallel port, and to
assign a port address.

If they are not enabled in the BIOS, they will not show up in DM.

What do you see in DM for Ports and if you need help, what is your
system info?

Click Start, Run and in the box enter:

msinfo32

Click OK, and when the System Summary info appears, click Edit, Select
All, Copy and then paste
back here.

There will be some personal information (like System Name and User
Name), and whatever appears to
be private information to you, just delete from the pasted
information.


Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #8 (permalink)  
Old 10-14-2009, 11:52 AM
cvh
 
Posts: n/a
Re: COM port locked
I see the port in DM, thats not the problem.

The problem is when I go to DOS mode the port seems locked and then I have
to check/uncheck 'use auto set.' to get DOS to see the
port .


"Jose" <jose_ease@yahoo.com> wrote in message
news:a48f0eb2-5043-4f34-8f1d-acd403965a6a@b2g2000yqi.googlegroups.com...
On Oct 13, 12:07 pm, Christophe <nom...@gmail.com> wrote:
> Hello,
>
> I use XP professional 2002 SP2.
>
> I need an old DOS program to access a external MODEM on COM1.
>
> When I start XP and try to access the port it says that the port is not
> available. Then I go into device manager => select the port => go to
> resources tab and check/uncheck 'use automatic settings'.
>
> Now when I go into DOS mode I type MODE and there it is the port is
> available.
>
> When I restart my computer the settings are not changed in device
> manager, but the port is gone again, so i need to check/uncheck
> the same settings and the port shows up again in Dos mode.
>
> I have no idea how to make the port available from startup...
>
> Thanks in advance,
>
> Christophe.
> Belgium.


If it does not show up in Device Manager under Ports when you reboot,
you should verify that it shows up and is enabled in the BIOS
configuration - before XP loads. Press whatever key you need to press
to get into the BIOS.

For example, my BIOS has a setting:

Serial Port1 Address
Use this item to enable or disable the onboard COM1/2 serial ports,
and to assign each port an address.

My Parallel Port has the same thing:

Parallel Port Address
Use this item to enable or disable the onboard Parallel port, and to
assign a port address.

If they are not enabled in the BIOS, they will not show up in DM.

What do you see in DM for Ports and if you need help, what is your
system info?

Click Start, Run and in the box enter:

msinfo32

Click OK, and when the System Summary info appears, click Edit, Select
All, Copy and then paste
back here.

There will be some personal information (like System Name and User
Name), and whatever appears to
be private information to you, just delete from the pasted
information.


Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #9 (permalink)  
Old 10-16-2009, 02:55 PM
Tschurin
 
Posts: n/a
RE: COM port locked
Christophe

I don't know if you've already solved your problem, but did you by any
chance happen to recently install the big Microsoft Security update?

"Christophe" wrote:

> Hello,
>
> I use XP professional 2002 SP2.
>
> I need an old DOS program to access a external MODEM on COM1.
>
> When I start XP and try to access the port it says that the port is not
> available. Then I go into device manager => select the port => go to
> resources tab and check/uncheck 'use automatic settings'.
>
> Now when I go into DOS mode I type MODE and there it is the port is
> available.
>
> When I restart my computer the settings are not changed in device
> manager, but the port is gone again, so i need to check/uncheck
> the same settings and the port shows up again in Dos mode.
>
> I have no idea how to make the port available from startup...
>
> Thanks in advance,
>
> Christophe.
> Belgium.
>
>

Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #10 (permalink)  
Old 10-20-2009, 07:21 AM
cvh
 
Posts: n/a
Re: COM port locked
No i didn't.


"Tschurin" <Tschurin@discussions.microsoft.com> wrote in message
news:BADAA9BB-51BC-435B-A7B8-1C9BED31BA8C@microsoft.com...
> Christophe
>
> I don't know if you've already solved your problem, but did you by any
> chance happen to recently install the big Microsoft Security update?
>
> "Christophe" wrote:
>
>> Hello,
>>
>> I use XP professional 2002 SP2.
>>
>> I need an old DOS program to access a external MODEM on COM1.
>>
>> When I start XP and try to access the port it says that the port is not
>> available. Then I go into device manager => select the port => go to
>> resources tab and check/uncheck 'use automatic settings'.
>>
>> Now when I go into DOS mode I type MODE and there it is the port is
>> available.
>>
>> When I restart my computer the settings are not changed in device
>> manager, but the port is gone again, so i need to check/uncheck
>> the same settings and the port shows up again in Dos mode.
>>
>> I have no idea how to make the port available from startup...
>>
>> Thanks in advance,
>>
>> Christophe.
>> Belgium.
>>
>>



Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:36 PM.




Recommended Download



Design by Vjacheslav Trushkin for phpBBStyles.com.
Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.1.0

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74